aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorMaximilian Bosch <maximilian@mbosch.me>2024-05-08 10:00:56 +0200
committerMaximilian Bosch <maximilian@mbosch.me>2024-05-08 23:03:28 +0200
commita4c943403fc7007956f562c381ebbc072d6cb94d (patch)
tree9bc8beb28f77793bef87cce76658892915fc2c24 /package.nix
parent8552519bb81fc2ee2d11e76594fd7de9393f4fe9 (diff)
flake: update nixpkgs input to latest nixos-23.11
This includes the update to libseccomp 2.5.5[1], so we don't need to override it on our own. [1] https://nixpk.gs/pr-tracker.html?pr=306070 Change-Id: I1fa9c7fcc23e501d75f774745107c6bb086ced70
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix17
1 files changed, 3 insertions, 14 deletions
diff --git a/package.nix b/package.nix
index 7c92cdfcb..0186b7472 100644
--- a/package.nix
+++ b/package.nix
@@ -19,14 +19,12 @@
curl,
doxygen,
editline,
- fetchurl,
flex,
git,
gtest,
jq,
libarchive,
libcpuid,
- libseccomp-nix ? __forDefaults.libseccomp-nix,
libseccomp,
libsodium,
lsof,
@@ -77,15 +75,6 @@
lix-doc = pkgs.callPackage ./lix-doc/package.nix { };
build-release-notes = pkgs.callPackage ./maintainers/build-release-notes.nix { };
-
- # FIXME remove when we have libsecomp 2.5.5 (currently in staging-23.11)
- libseccomp-nix = libseccomp.overrideAttrs (_: rec {
- version = "2.5.5";
- src = fetchurl {
- url = "https://github.com/seccomp/libseccomp/releases/download/v${version}/libseccomp-${version}.tar.gz";
- hash = "sha256-JIosik2bmFiqa69ScSw0r+/PnJ6Ut23OAsHJqiX7M3U=";
- };
- });
},
}:
let
@@ -258,7 +247,7 @@ stdenv.mkDerivation (finalAttrs: {
lix-doc
]
++ lib.optionals stdenv.hostPlatform.isLinux [
- libseccomp-nix
+ libseccomp
busybox-sandbox-shell
]
++ lib.optional internalApiDocs rapidcheck
@@ -373,10 +362,10 @@ stdenv.mkDerivation (finalAttrs: {
passthru.perl-bindings = pkgs.callPackage ./perl { inherit fileset stdenv; };
- # Export the patched version of boehmgc & libseccomp.
+ # Export the patched version of boehmgc.
# flake.nix exports that into its overlay.
passthru = {
- inherit (__forDefaults) boehmgc-nix build-release-notes libseccomp-nix;
+ inherit (__forDefaults) boehmgc-nix build-release-notes;
# The collection of dependency logic for this derivation is complicated enough that
# it's easier to parameterize the devShell off an already called package.nix.