aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorQyriad <qyriad@qyriad.me>2024-03-21 15:38:11 -0600
committereldritch horrors <pennae@lix.systems>2024-03-26 00:43:33 +0100
commite1ffe56793be79dfea203121ecafff3d0baa29ba (patch)
treed337477251bc4187820ba0388c63e1c4d6a9c5f5 /package.nix
parentd3d7489571baeb651d3843dba3b638621694c174 (diff)
meson: implement unit tests
Unit tests can be run with `meson test -C build --suite check`. `--suite check` is optional, as right now that's the only test suite, but when functional tests are added those will be in a separate suite. Change-Id: I7f22f1cde4b489b3cdb5f9a36a544f0c409fcc1f
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/package.nix b/package.nix
index 4b4c35731..1392bbe62 100644
--- a/package.nix
+++ b/package.nix
@@ -251,6 +251,10 @@ in stdenv.mkDerivation (finalAttrs: {
doCheck = true;
+ mesonCheckFlags = lib.optionals (buildWithMeson || forDevShell) [
+ "--suite=check"
+ ];
+
installFlags = "sysconfdir=$(out)/etc";
postInstall = lib.optionalString (!finalAttrs.dontBuild) ''