aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-08-09 23:24:17 -0700
committerJade Lovelace <lix@jade.fyi>2024-08-10 16:10:16 -0700
commit0c7619535112e19232384e15e82ffa6a5af7569d (patch)
treec9500d6bc74b50a8bb39f580ebf5389de10e786c /package.nix
parent292567e0b0a4681eb8ca803c26293d70857fe387 (diff)
build: remove expect as a dependency
I was packaging Lix 2.91 for nixpkgs and was annoyed at the expect dependency. Turns out that you can replace unbuffer with a pretty-short Python script. It became less short after I found out that Linux was converting \n to \r\n in the terminal subsystem, which was not very funny, but is at least solved by twiddling termios bits. Change-Id: I8a2700abcbbf6a9902e01b05b40fa9340c0ab90c
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix3
1 files changed, 0 insertions, 3 deletions
diff --git a/package.nix b/package.nix
index 18c8475bb..295e9139f 100644
--- a/package.nix
+++ b/package.nix
@@ -20,7 +20,6 @@
doxygen,
editline-lix ? __forDefaults.editline-lix,
editline,
- expect,
git,
gtest,
jq,
@@ -275,8 +274,6 @@ stdenv.mkDerivation (finalAttrs: {
# configure, but we don't actually want to *run* the checks here.
++ lib.optionals lintInsteadOfBuild finalAttrs.checkInputs;
- nativeCheckInputs = [ expect ];
-
checkInputs = [
gtest
rapidcheck