aboutsummaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorGraham Christensen <graham@grahamc.com>2017-07-09 12:38:32 -0400
committerGraham Christensen <graham@grahamc.com>2017-07-14 11:42:33 -0400
commita0ad8ba12ee26edf0bf5f221b080a61c0d24a874 (patch)
tree2bfea6b6438ece4ea71b1531519d549e9221ea2c /release.nix
parent112ff7833d4f3a233755b2fe856b2eb2b3723254 (diff)
Shellcheck the existing installer
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/release.nix b/release.nix
index 1348ef7b9..86a7350d5 100644
--- a/release.nix
+++ b/release.nix
@@ -137,7 +137,7 @@ let
runCommand "nix-binary-tarball-${version}"
{ exportReferencesGraph = [ "closure1" toplevel "closure2" cacert ];
- buildInputs = [ perl ];
+ buildInputs = [ perl shellcheck ];
meta.description = "Distribution-independent Nix bootstrap binaries for ${system}";
}
''
@@ -146,6 +146,9 @@ let
substitute ${./scripts/install-nix-from-closure.sh} $TMPDIR/install \
--subst-var-by nix ${toplevel} \
--subst-var-by cacert ${cacert}
+
+ shellcheck -e SC1090 $TMPDIR/install
+
chmod +x $TMPDIR/install
dir=nix-${version}-${system}
fn=$out/$dir.tar.bz2