aboutsummaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2015-03-24 11:50:22 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2015-03-24 11:52:34 +0100
commitfd89f97be97d4f698efd208140062a3f701ef76e (patch)
tree40bde26dc89c301630721ecec2f934b2677a2536 /release.nix
parent5ce50cd99e740d0d0f18c30327ae687be9356553 (diff)
Add the closure of store paths to the chroot
Thus, for example, to get /bin/sh in a chroot, you only need to specify /bin/sh=${pkgs.bash}/bin/sh in build-chroot-dirs. The dependencies of sh will be added automatically.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/release.nix b/release.nix
index c5f700d8e..47ba1c1c3 100644
--- a/release.nix
+++ b/release.nix
@@ -95,11 +95,10 @@ let
# Provide a default value for the ‘build-chroot-dirs’ setting
# that includes /bin/sh pointing to bash.
- preHook = lib.optionalString stdenv.isLinux (
- let sh = stdenv.shell; in
+ preHook = lib.optionalString stdenv.isLinux
''
- export DEFAULT_CHROOT_DIRS="/bin/sh=${sh} $(tr '\n' ' ' < ${writeReferencesToFile sh})"
- '');
+ export DEFAULT_CHROOT_DIRS="/bin/sh=${stdenv.shell}"
+ '';
enableParallelBuilding = true;