aboutsummaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2016-11-16 12:46:43 +0100
committeraszlig <aszlig@redmoonstudios.org>2016-11-16 16:48:34 +0100
commit651a18dd2466662e7027e4dc04147e4f38c7bbf8 (patch)
tree10e617243eb0fa5a7e76f99dfcc4885ccfa12a94 /release.nix
parentb90a43533249a50f238a5e6cc9d77edb0fe6d748 (diff)
release.nix: Add a test for sandboxing
Right now it only tests whether seccomp correctly forges the return value of chown, but the long-term goal is to test the full sandboxing functionality at some point in the future. Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/release.nix b/release.nix
index fbed401df..958460d6f 100644
--- a/release.nix
+++ b/release.nix
@@ -200,6 +200,10 @@ let
nix = build.x86_64-linux; system = "x86_64-linux";
});
+ tests.sandbox = (import ./tests/sandbox.nix rec {
+ nix = build.x86_64-linux; system = "x86_64-linux";
+ });
+
tests.binaryTarball =
with import <nixpkgs> { system = "x86_64-linux"; };
vmTools.runInLinuxImage (runCommand "nix-binary-tarball-test"