aboutsummaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2018-03-20 14:55:47 +0100
committerEelco Dolstra <edolstra@gmail.com>2018-03-20 14:55:47 +0100
commit78d0c72b52835161fd15058b111aa05d69ce062b (patch)
tree3da66ec33eee5876213985892669a98deb6e4deb /release.nix
parentf5a2136a404553ce3462be0541123a3532bc0ab0 (diff)
Fix coverage job
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix12
1 files changed, 5 insertions, 7 deletions
diff --git a/release.nix b/release.nix
index 0dac174ac..bdcb6f759 100644
--- a/release.nix
+++ b/release.nix
@@ -155,17 +155,15 @@ let
coverage =
- with import nixpkgs { system = "x86_64-linux"; };
+ with pkgs;
+
+ with import ./release-common.nix { inherit pkgs; };
releaseTools.coverageAnalysis {
name = "nix-build";
src = tarball;
- buildInputs =
- [ curl bzip2 openssl pkgconfig sqlite xz libsodium libseccomp
- # These are for "make check" only:
- graphviz libxml2 libxslt git mercurial
- ];
+ buildInputs = buildDeps;
configureFlags = ''
--disable-init-state
@@ -175,7 +173,7 @@ let
doInstallCheck = true;
- lcovFilter = [ "*-tab.*" "*/nlohmann/*" "*/linenoise/*" ];
+ lcovFilter = [ "*/boost/*" "*-tab.*" "*/nlohmann/*" "*/linenoise/*" ];
# We call `dot', and even though we just use it to
# syntax-check generated dot files, it still requires some