aboutsummaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2018-03-14 19:11:13 +0100
committerEelco Dolstra <edolstra@gmail.com>2018-03-14 19:25:09 +0100
commitc04bca34016c41d1fcab222e2d61a26a285340c6 (patch)
treee1323fa3c0755065656a8e6c33edb8785950718d /release.nix
parentca14b142001ab467e679d4ed0cc6236180bf34b2 (diff)
Factor out commonality between release.nix and shell.nix
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix28
1 files changed, 4 insertions, 24 deletions
diff --git a/release.nix b/release.nix
index 2e9292955..7db5e20e1 100644
--- a/release.nix
+++ b/release.nix
@@ -14,6 +14,8 @@ let
tarball =
with pkgs;
+ with import ./release-common.nix { inherit pkgs; };
+
releaseTools.sourceTarball {
name = "nix-tarball";
version = builtins.readFile ./version;
@@ -21,13 +23,7 @@ let
src = nix;
inherit officialRelease;
- buildInputs =
- [ curl bison flex libxml2 libxslt
- bzip2 xz brotli
- pkgconfig sqlite libsodium boehmgc
- docbook5 docbook5_xsl
- autoconf-archive
- ] ++ lib.optional stdenv.isLinux libseccomp;
+ buildInputs = tarballDeps ++ buildDeps;
configureFlags = "--enable-gc";
@@ -67,23 +63,7 @@ let
name = "nix";
src = tarball;
- buildInputs =
- [ curl
- bzip2 xz brotli
- openssl pkgconfig sqlite boehmgc
- boost
-
- # Tests
- git
- mercurial
- ]
- ++ lib.optional stdenv.isLinux libseccomp
- ++ lib.optional (stdenv.isLinux || stdenv.isDarwin) libsodium
- ++ lib.optional (stdenv.isLinux || stdenv.isDarwin)
- (aws-sdk-cpp.override {
- apis = ["s3"];
- customMemoryManagement = false;
- });
+ buildInputs = buildDeps;
configureFlags = configureFlags ++
[ "--sysconfdir=/etc" ];