diff options
author | Eelco Dolstra <edolstra@gmail.com> | 2019-05-02 21:10:13 +0200 |
---|---|---|
committer | Eelco Dolstra <edolstra@gmail.com> | 2019-05-02 21:10:13 +0200 |
commit | 2919c496ea10a99d08baffbef485cfb719233b9f (patch) | |
tree | ce114825d71789122a00e717ca0d1bee2754f7c9 /shell.nix | |
parent | 7dcf5b011a0942ecf953f2b607c4c8d0e9e652c7 (diff) |
nix dev-shell: Use 'provides.devShell' by default
Thus
$ nix dev-shell
will now build the 'provides.devShell' attribute from the flake in the
current directory. If it doesn't exist, it falls back to
'provides.defaultPackage'.
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 6 |
1 files changed, 4 insertions, 2 deletions
@@ -1,6 +1,8 @@ -{ useClang ? false }: +{ useClang ? false +, nixpkgs ? builtins.fetchTarball https://github.com/NixOS/nixpkgs-channels/archive/nixos-19.03.tar.gz +}: -with import (builtins.fetchTarball https://github.com/NixOS/nixpkgs-channels/archive/nixos-19.03.tar.gz) {}; +with import nixpkgs { system = builtins.currentSystem or "x86_64-linux"; }; with import ./release-common.nix { inherit pkgs; }; |