aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2019-05-02 21:10:13 +0200
committerEelco Dolstra <edolstra@gmail.com>2019-05-02 21:10:13 +0200
commit2919c496ea10a99d08baffbef485cfb719233b9f (patch)
treece114825d71789122a00e717ca0d1bee2754f7c9 /shell.nix
parent7dcf5b011a0942ecf953f2b607c4c8d0e9e652c7 (diff)
nix dev-shell: Use 'provides.devShell' by default
Thus $ nix dev-shell will now build the 'provides.devShell' attribute from the flake in the current directory. If it doesn't exist, it falls back to 'provides.defaultPackage'.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 8167f87a2..d7e63bad3 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,6 +1,8 @@
-{ useClang ? false }:
+{ useClang ? false
+, nixpkgs ? builtins.fetchTarball https://github.com/NixOS/nixpkgs-channels/archive/nixos-19.03.tar.gz
+}:
-with import (builtins.fetchTarball https://github.com/NixOS/nixpkgs-channels/archive/nixos-19.03.tar.gz) {};
+with import nixpkgs { system = builtins.currentSystem or "x86_64-linux"; };
with import ./release-common.nix { inherit pkgs; };