aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2020-02-18 22:58:12 +0100
committerEelco Dolstra <edolstra@gmail.com>2020-02-18 22:59:55 +0100
commit50cf77cecd6ed2c98fab1651e54f7a8dcc162db6 (patch)
treecadb29613299ecaa24cfead6c3665ad647850577 /shell.nix
parentdd032f624cae1b705f30db57b468484050564a4a (diff)
Remove outdated shell.nix
Looks like this got accidentally revived after 204291f0598c43b10cf20a89b49fc63624d78c7c.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/shell.nix b/shell.nix
deleted file mode 100644
index e5a2b2c91..000000000
--- a/shell.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-{ useClang ? false }:
-
-with import (builtins.fetchTarball https://github.com/NixOS/nixpkgs/archive/nixos-19.09.tar.gz) {};
-
-with import ./release-common.nix { inherit pkgs; };
-
-(if useClang then clangStdenv else stdenv).mkDerivation {
- name = "nix";
-
- buildInputs = buildDeps ++ tarballDeps ++ perlDeps ++ [ pkgs.rustfmt ];
-
- inherit configureFlags;
-
- enableParallelBuilding = true;
-
- installFlags = "sysconfdir=$(out)/etc";
-
- shellHook =
- ''
- export prefix=$(pwd)/inst
- configureFlags+=" --prefix=$prefix"
- PKG_CONFIG_PATH=$prefix/lib/pkgconfig:$PKG_CONFIG_PATH
- PATH=$prefix/bin:$PATH
- '';
-}