diff options
author | Eelco Dolstra <edolstra@gmail.com> | 2020-03-13 14:05:49 +0100 |
---|---|---|
committer | Eelco Dolstra <edolstra@gmail.com> | 2020-03-13 18:05:22 +0100 |
commit | 7c39201bcb181653af2bafee2fc02d1bcc58691b (patch) | |
tree | 3d2214538c1b21401e2073edc2c6291fa64b93d7 /shell.nix | |
parent | eab7d790a36ff0aa648321a39eaeaa4248755156 (diff) |
Remove the tarball job
Source tarballs are not very useful anymore. People who want to build
from source can also just build from the Git repository. Once upon a
time, the source tarball also saved users from needing a few
dependencies (e.g. bison and flex) but those are dwarfed by the other
dependencies, so it's no longer worth it.
Note: the release script should be updated to copy the vendoredCrates
tarball.
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -7,7 +7,7 @@ with import ./release-common.nix { inherit pkgs; }; (if useClang then clangStdenv else stdenv).mkDerivation { name = "nix"; - buildInputs = buildDeps ++ propagatedDeps ++ tarballDeps ++ perlDeps ++ [ pkgs.rustfmt ]; + buildInputs = buildDeps ++ propagatedDeps ++ perlDeps ++ [ pkgs.rustfmt ]; inherit configureFlags; |