aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2017-05-15 17:30:33 +0200
committerEelco Dolstra <edolstra@gmail.com>2017-05-15 17:36:32 +0200
commita2d92bb20e82a0957067ede60e91fab256948b41 (patch)
tree665a9274c830f73c05a282622d78f6cf8d7c9ec9 /shell.nix
parentb30f5784d0184688de964f6239e373b62101ebc4 (diff)
Add --with-sandbox-shell configure flag
And add a 116 KiB ash shell from busybox to the release build. This helps to make sandbox builds work out of the box on non-NixOS systems and with diverted stores.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/shell.nix b/shell.nix
index 8645d3602..c4e2a20f8 100644
--- a/shell.nix
+++ b/shell.nix
@@ -2,6 +2,8 @@
with import <nixpkgs> {};
+with import ./release-common.nix { inherit pkgs; };
+
(if useClang then clangStdenv else stdenv).mkDerivation {
name = "nix";
@@ -22,10 +24,7 @@ with import <nixpkgs> {};
perlPackages.DBDSQLite
];
- configureFlags =
- [ "--disable-init-state"
- "--enable-gc"
- ];
+ inherit configureFlags;
enableParallelBuilding = true;