diff options
author | stuebinm <stuebinm@disroot.org> | 2024-05-27 16:34:41 +0200 |
---|---|---|
committer | stuebinm <stuebinm@disroot.org> | 2024-05-27 16:47:40 +0200 |
commit | 0b91a4b0ec79c27ee36d8a7e2afd7737cb825b65 (patch) | |
tree | 7fd4175a6bc5e803a0589bdb90fa1ea27d606650 /shell.nix | |
parent | 2cd1ef2201cd046cbf041b52040c6e86efd927d8 (diff) |
shell.nix: conform to documentation
According to doc/manual/src/contributing/hacking.md, all development
shells should also be available in classic nix using the -A argument
to nix-shell, e.g.
nix-shell -A native-clangStdenvPackages
This was not actually the case; flake-compat generates attrsets like
nix-shell -A devShells.x86_64-linux.native-clangStdenvPackages
instead. These are unwieldy to use, so rather than changing the docs,
this changes the shell.nix file to result in the documented behavior.
Change-Id: I0920ccbdfddacf371f0aeaae7e290db65cf76ee7
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 10 |
1 files changed, 7 insertions, 3 deletions
@@ -1,3 +1,7 @@ -(import (fetchTarball "https://github.com/edolstra/flake-compat/archive/master.tar.gz") { - src = ./.; -}).shellNix +let + shell = + (import (fetchTarball "https://github.com/edolstra/flake-compat/archive/master.tar.gz") { + src = ./.; + }).shellNix; +in +shell.default // shell.devShells.${builtins.currentSystem} |