aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2003-07-28 12:19:23 +0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2003-07-28 12:19:23 +0000
commit949c4fa1a863a804bdf1f985b55d5259f18838ae (patch)
tree2a3bb052b6658025c365dab1b17c736b72a0b485 /src/Makefile.am
parentf21b3419575eec2b5bbcc12b035f21c23d57e24d (diff)
* `nix --help'.
* `nix --query --graph' to print a dot dependency graph of derive expressions.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 98d76b753..23e242919 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -33,6 +33,13 @@ libshared_a_CXXFLAGS = \
-DNIX_LOG_DIR=\"$(localstatedir)/log/nix\" \
$(AM_CXXFLAGS)
+nix.o: nix-help.txt.hh
+
+%.hh: %
+ echo -n '"' > $@
+ sed 's|\(.*\)|\1\\n\\|' < $< >> $@
+ echo '"' >> $@
+
install-data-local:
$(INSTALL) -d $(localstatedir)/nix
$(INSTALL) -d $(localstatedir)/nix/links
@@ -40,4 +47,4 @@ install-data-local:
$(INSTALL) -d $(prefix)/store
$(bindir)/nix --init
-EXTRA_DIST = *.hh *.h \ No newline at end of file
+EXTRA_DIST = *.hh *.h