aboutsummaryrefslogtreecommitdiff
path: root/src/libmain/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2004-02-16 15:23:19 +0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2004-02-16 15:23:19 +0000
commitf34de121401bb43c6cfab892b2b254e42652ba90 (patch)
tree7d421aefeabf597679a81a92139c9a338be2cfdd /src/libmain/Makefile.am
parentfbc48a469c80201f0d159a9b9f48a22ce5f36984 (diff)
* Allow the location of the store to be specified (--with-store-dir).
* Do not create stuff in localstatedir when doing `make install' (since we may not have write access). In general, installation of constant code/data should be separate from the initialisation of mutable state.
Diffstat (limited to 'src/libmain/Makefile.am')
-rw-r--r--src/libmain/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/libmain/Makefile.am b/src/libmain/Makefile.am
index 6d70b0406..72126f113 100644
--- a/src/libmain/Makefile.am
+++ b/src/libmain/Makefile.am
@@ -3,7 +3,7 @@ noinst_LIBRARIES = libmain.a
libmain_a_SOURCES = shared.cc shared.hh
AM_CXXFLAGS = \
- -DNIX_STORE_DIR=\"$(prefix)/store\" \
+ -DNIX_STORE_DIR=\"$(storedir)\" \
-DNIX_DATA_DIR=\"$(datadir)\" \
-DNIX_STATE_DIR=\"$(localstatedir)/nix\" \
-DNIX_LOG_DIR=\"$(localstatedir)/log/nix\" \