aboutsummaryrefslogtreecommitdiff
path: root/src/libutil/meson.build
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-03-19 18:02:22 +0100
committereldritch horrors <pennae@lix.systems>2024-07-03 11:46:53 +0000
commit73ddc4540f5f85ef9e01be4e2e362c6c88e47fa3 (patch)
tree6f6ff06799a365d2e2111c8b735111fdd587e166 /src/libutil/meson.build
parent45ac449d3970bc6abc4c04e0b3a3b6768a9cb753 (diff)
libutil: generator type with on-yield value mapping
this will be the basis of non-boost coroutines in lix. anything that is a boost coroutine *should* be representable with a Generator coroutine, and many things that are not currently boost coroutines but behave much like one (such as, notably, serializers) should be as well. this allows us to greatly simplify many things that look like iteration but aren't. Change-Id: I2cebcefa0148b631fb30df4c8cfa92167a407e34
Diffstat (limited to 'src/libutil/meson.build')
-rw-r--r--src/libutil/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/libutil/meson.build b/src/libutil/meson.build
index f6d14a11b..211196c60 100644
--- a/src/libutil/meson.build
+++ b/src/libutil/meson.build
@@ -72,6 +72,7 @@ libutil_headers = files(
'file-system.hh',
'finally.hh',
'fmt.hh',
+ 'generator.hh',
'git.hh',
'hash.hh',
'hilite.hh',