aboutsummaryrefslogtreecommitdiff
path: root/src/nix-store/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2010-05-31 16:36:24 +0000
committerLudovic Courtès <ludo@gnu.org>2010-05-31 16:36:24 +0000
commit8bcdd36f10c5adfd312493c822c95c6fa5fbd110 (patch)
tree902a9d2e37e0f7db536a204d66329ba8835e8b39 /src/nix-store/Makefile.am
parentda52f8bea0620cd55e10a8ec90306fa169f2d14f (diff)
Add XML output to `nix-store'.
* src/nix-store/Makefile.am (nix_store_SOURCES): Add `xmlgraph.cc' and `xmlgraph.hh'. * src/nix-store/help.txt (Operations): Document `--xml'. * src/nix-store/nix-store.cc (opQuery): Handle `--xml'. * src/nix-store/xmlgraph.cc, src/nix-store/xmlgraph.hh: New files.
Diffstat (limited to 'src/nix-store/Makefile.am')
-rw-r--r--src/nix-store/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/nix-store/Makefile.am b/src/nix-store/Makefile.am
index 9a439dd92..b6dd37a61 100644
--- a/src/nix-store/Makefile.am
+++ b/src/nix-store/Makefile.am
@@ -1,6 +1,9 @@
bin_PROGRAMS = nix-store
-nix_store_SOURCES = nix-store.cc dotgraph.cc dotgraph.hh help.txt
+nix_store_SOURCES = \
+ nix-store.cc dotgraph.cc dotgraph.hh help.txt \
+ xmlgraph.cc xmlgraph.hh
+
nix_store_LDADD = ../libmain/libmain.la ../libstore/libstore.la ../libutil/libutil.la \
../boost/format/libformat.la @ADDITIONAL_NETWORK_LIBS@