aboutsummaryrefslogtreecommitdiff
path: root/src/nix-store/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2012-10-03 16:37:06 -0400
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-10-03 16:40:09 -0400
commita562d544d8520a0f113ad1a348e28ea00f27b693 (patch)
tree5e8d7200b8521aa54e2c8846ef7c31fd5dac737e /src/nix-store/Makefile.am
parent9c41c66c5b877dbb529f6147b28384a57a591895 (diff)
When ‘--help’ is given, just run ‘man’ to show the manual page
I.e. do what git does. I'm too lazy to keep the builtin help text up to date :-) Also add ‘--help’ to various commands that lacked it (e.g. nix-collect-garbage).
Diffstat (limited to 'src/nix-store/Makefile.am')
-rw-r--r--src/nix-store/Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/src/nix-store/Makefile.am b/src/nix-store/Makefile.am
index ef8d760d6..fca9eff7c 100644
--- a/src/nix-store/Makefile.am
+++ b/src/nix-store/Makefile.am
@@ -1,17 +1,12 @@
bin_PROGRAMS = nix-store
-nix_store_SOURCES = \
- nix-store.cc dotgraph.cc dotgraph.hh help.txt \
+nix_store_SOURCES = \
+ nix-store.cc dotgraph.cc dotgraph.hh \
xmlgraph.cc xmlgraph.hh
nix_store_LDADD = ../libmain/libmain.la ../libstore/libstore.la ../libutil/libutil.la \
../boost/format/libformat.la -lbz2
-nix-store.o: help.txt.hh
-
-%.txt.hh: %.txt
- ../bin2c/bin2c helpText < $< > $@ || (rm $@ && exit 1)
-
AM_CXXFLAGS = \
-I$(srcdir)/.. -I$(srcdir)/../libutil \
-I$(srcdir)/../libstore -I$(srcdir)/../libmain