aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2005-01-25 17:08:52 +0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2005-01-25 17:08:52 +0000
commit066da4ab852ebe4288536149824ea175dc36cad4 (patch)
treed9258a2d224a0574c0135cd799cb704fc8c25433 /tests/Makefile.am
parentc6290e42bc8890e2036013773a98e3551352c91a (diff)
* Really fix the substitute mechanism, i.e., ensure the closure
invariant by registering references through the manifest. * Added a test for nix-pull.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d91b021ca..9094d39f5 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -8,7 +8,16 @@ TESTS_ENVIRONMENT = TEST_ROOT=$(TEST_ROOT) \
NIX_LOG_DIR=$(TEST_ROOT)/log \
NIX_STATE_DIR=$(TEST_ROOT)/state \
NIX_DB_DIR=$(TEST_ROOT)/db \
+ NIX_BIN_DIR=$(TEST_ROOT)/bin \
+ NIX_LIBEXEC_DIR=$(TEST_ROOT)/bin \
+ NIX_LOCALSTATE_DIR=$(TEST_ROOT)/state \
+ REAL_BIN_DIR=$(bindir) \
+ REAL_LIBEXEC_DIR=$(libexecdir) \
+ REAL_LOCALSTATE_DIR=$(localstatedir) \
+ REAL_DATA_DIR=$(datadir) \
+ REAL_STORE_DIR=$(storedir) \
NIX_BUILD_HOOK= \
+ PERL=$(perl) \
TOP=$(shell pwd)/.. \
SHARED=$(extra1) \
aterm_bin=$(aterm_bin) \
@@ -22,9 +31,14 @@ build-hook.sh: build-hook.nix
substitutes.sh: substitutes.nix
substitutes2.sh: substitutes2.nix
fallback.sh: fallback.nix
+nix-push.sh: dependencies.nix
+nix-pull.sh: dependencies.nix
-TESTS = init.sh hash.sh lang.sh simple.sh dependencies.sh locking.sh parallel.sh \
- build-hook.sh substitutes.sh substitutes2.sh fallback.sh verify.sh
+#TESTS = init.sh hash.sh lang.sh simple.sh dependencies.sh locking.sh parallel.sh \
+# build-hook.sh substitutes.sh substitutes2.sh fallback.sh nix-push.sh verify.sh \
+# nix-pull.sh
+
+TESTS = init.sh nix-push.sh nix-pull.sh
XFAIL_TESTS =