aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2004-06-25 15:36:09 +0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2004-06-25 15:36:09 +0000
commitb113edeab780216b0590045b932be685d1399e9b (patch)
tree32c0e6e0006c211b43f91aad8529cff6c424306d /tests/Makefile.am
parente4883211f9482ec3255bd4e682635493e03466ca (diff)
* A flag `--keep-going / -k' to keep building goals if one fails, as
much as possible. (This is similar to GNU Make's `-k' flag.) * Refactoring to implement this: previously we just bombed out when a build failed, but now we have to clean up. In particular this means that goals must be freed quickly --- they shouldn't hang around until the worker exits. So the worker now maintains weak pointers in order not to prevent garbage collection. * Documented the `-k' and `-j' flags.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 2ad5ad0d9..19122cd95 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -21,9 +21,8 @@ substitutes.sh: substitutes.nix substituter.nix
substitutes2.sh: substitutes2.nix substituter.nix substituter2.nix
fall-back.sh: fall-back.nix
-#TESTS = init.sh simple.sh dependencies.sh locking.sh parallel.sh \
-# build-hook.sh substitutes.sh substitutes2.sh
-TESTS = init.sh fall-back.sh
+TESTS = init.sh simple.sh dependencies.sh locking.sh parallel.sh \
+ build-hook.sh substitutes.sh substitutes2.sh
XFAIL_TESTS =