aboutsummaryrefslogtreecommitdiff
path: root/tests/big-derivation-attr.nix
diff options
context:
space:
mode:
authorThéophane Hufschmitt <7226587+thufschmitt@users.noreply.github.com>2022-03-01 13:58:17 +0100
committerGitHub <noreply@github.com>2022-03-01 13:58:17 +0100
commit47dec825c5daeeb9d615eb4d1eead3dbaa06c7c9 (patch)
tree9d4426dfe847570906487649c32c5b320697705c /tests/big-derivation-attr.nix
parent79152e307e7eef667c3de9c21571d017654a7c32 (diff)
parentdc92b01885c0c49d094148b1c4dc871ccdd265ad (diff)
Merge pull request #6181 from obsidiansystems/auto-uid-allocation
Auto uid allocation -- update with latest master
Diffstat (limited to 'tests/big-derivation-attr.nix')
-rw-r--r--tests/big-derivation-attr.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/big-derivation-attr.nix b/tests/big-derivation-attr.nix
new file mode 100644
index 000000000..35c1187f6
--- /dev/null
+++ b/tests/big-derivation-attr.nix
@@ -0,0 +1,13 @@
+let
+ sixteenBytes = "0123456789abcdef";
+ times16 = s: builtins.concatStringsSep "" [s s s s s s s s s s s s s s s s];
+ exp = n: x: if n == 1 then x else times16 (exp (n - 1) x);
+ sixteenMegabyte = exp 6 sixteenBytes;
+in
+assert builtins.stringLength sixteenMegabyte == 16777216;
+derivation {
+ name = "big-derivation-attr";
+ builder = "/x";
+ system = "y";
+ bigAttr = sixteenMegabyte;
+}