aboutsummaryrefslogtreecommitdiff
path: root/tests/ca/content-addressed.nix
diff options
context:
space:
mode:
authorPeter Waller <p@pwaller.net>2023-06-30 16:11:12 +0100
committerPeter Waller <p@pwaller.net>2023-08-09 20:57:04 +0100
commit4b1bd822ac7fd35b30f37c1b7705c523cc462761 (patch)
tree22c91ef24746ea7d7f3ab423a605742e55087c3c /tests/ca/content-addressed.nix
parentd00fe5f22559efc6f8b4b92eab537b08c0e43dee (diff)
Try to realise CA derivations during queryMissing
This enables nix to correctly report what will be fetched in the case that everything is a cache hit. Note however that if an intermediate build of something which is not cached could still cause products to end up being substituted if the intermediate build results in a CA path which is in the cache. Fixes #8615. Signed-off-by: Peter Waller <p@pwaller.net>
Diffstat (limited to 'tests/ca/content-addressed.nix')
-rw-r--r--tests/ca/content-addressed.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/ca/content-addressed.nix b/tests/ca/content-addressed.nix
index 81bc4bf5c..2559c562f 100644
--- a/tests/ca/content-addressed.nix
+++ b/tests/ca/content-addressed.nix
@@ -61,6 +61,24 @@ rec {
echo ${rootCA}/non-ca-hello > $out/dep
'';
};
+ dependentForBuildCA = mkCADerivation {
+ name = "dependent-for-build-ca";
+ buildCommand = ''
+ echo "Depends on rootCA for building only"
+ mkdir -p $out
+ echo ${rootCA}
+ touch $out
+ '';
+ };
+ dependentForBuildNonCA = mkDerivation {
+ name = "dependent-for-build-non-ca";
+ buildCommand = ''
+ echo "Depends on rootCA for building only"
+ mkdir -p $out
+ echo ${rootCA}
+ touch $out
+ '';
+ };
dependentFixedOutput = mkDerivation {
name = "dependent-fixed-output";
outputHashMode = "recursive";