aboutsummaryrefslogtreecommitdiff
path: root/tests/check-refs.nix
diff options
context:
space:
mode:
authorNaïm Favier <n@monade.li>2022-09-23 23:30:29 +0200
committerNaïm Favier <n@monade.li>2023-01-03 17:19:16 +0100
commit15f7fa59bec1dbb4fa94bc1c2f9018b1f14f0d65 (patch)
tree16772ce4d4c9a8c9f0f4c0d55c39ce4f75065e47 /tests/check-refs.nix
parent15341334b50b2b432830a8e78abc331d0a47de13 (diff)
`unsafeDiscardReferences`
Adds a new boolean structured attribute `outputChecks.<output>.unsafeDiscardReferences` which disables scanning an output for runtime references. __structuredAttrs = true; outputChecks.out.unsafeDiscardReferences = true; This is useful when creating filesystem images containing their own embedded Nix store: they are self-contained blobs of data with no runtime dependencies. Setting this attribute requires the experimental feature `discard-references` to be enabled.
Diffstat (limited to 'tests/check-refs.nix')
-rw-r--r--tests/check-refs.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/check-refs.nix b/tests/check-refs.nix
index 9d90b0920..a5e40c9e5 100644
--- a/tests/check-refs.nix
+++ b/tests/check-refs.nix
@@ -67,4 +67,13 @@ rec {
disallowedReferences = [test5];
};
+ test11 = makeTest 11 {
+ __structuredAttrs = true;
+ outputChecks.out = {
+ unsafeDiscardReferences = true;
+ allowedReferences = [];
+ };
+ buildCommand = ''echo ${dep} > "''${outputs[out]}"'';
+ };
+
}