aboutsummaryrefslogtreecommitdiff
path: root/tests/export-graph.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2009-03-18 17:36:42 +0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2009-03-18 17:36:42 +0000
commit28972864879a63c4110211d9852b692672869a2a (patch)
treeb7dc88b7a10f2f65aea0cbe553d985ddb6f3f67f /tests/export-graph.nix
parente530e0a35041b3135b521f1b2dbc21fabfb00d47 (diff)
* Unify exportReferencesGraph and exportBuildReferencesGraph, and make
sure that it works as expected when you pass it a derivation. That is, we have to make sure that all build-time dependencies are built, and that they are all in the input closure (otherwise remote builds might fail, for example). This is ensured at instantiation time by adding all derivations and their sources to inputDrvs and inputSrcs.
Diffstat (limited to 'tests/export-graph.nix')
-rw-r--r--tests/export-graph.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/export-graph.nix b/tests/export-graph.nix
index d65ad8c14..3a0b0368d 100644
--- a/tests/export-graph.nix
+++ b/tests/export-graph.nix
@@ -4,12 +4,13 @@ rec {
printRefs =
''
+ echo $exportReferencesGraph
while read path; do
read drv
read nrRefs
echo "$path has $nrRefs references"
echo "$path" >> $out
- for ((n = 0; n < $nrRefs; n++)); do read ref; echo "ref $ref"; done
+ for ((n = 0; n < $nrRefs; n++)); do read ref; echo "ref $ref"; test -e "$ref"; done
done < refs
'';
@@ -22,7 +23,7 @@ rec {
buildGraph = mkDerivation {
name = "dependencies";
builder = builtins.toFile "build-graph-builder" "${printRefs}";
- exportBuildReferencesGraph = ["refs" (import ./dependencies.nix).drvPath];
+ exportReferencesGraph = ["refs" (import ./dependencies.nix).drvPath];
};
}