aboutsummaryrefslogtreecommitdiff
path: root/tests/export-graph.nix
diff options
context:
space:
mode:
authorGuillaume Girol <symphorien+git@xlumurb.eu>2023-08-23 12:00:00 +0000
committerGuillaume Girol <symphorien+git@xlumurb.eu>2023-08-24 11:37:24 +0200
commit925a444b925590df90e19d3c0071936f87d2b43d (patch)
tree085a36dc6f2972ad5ac676d95231ec29b027a8ea /tests/export-graph.nix
parent6459a1c7ad1ad1a88fae42f9737e969c6ae89679 (diff)
add nix-store --query --valid-derivers command
notably useful when nix-store --query --deriver returns a non-existing path. Co-authored-by: Felix Uhl <iFreilicht@users.noreply.github.com>
Diffstat (limited to 'tests/export-graph.nix')
-rw-r--r--tests/export-graph.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/export-graph.nix b/tests/export-graph.nix
index fdac9583d..64fe36bd1 100644
--- a/tests/export-graph.nix
+++ b/tests/export-graph.nix
@@ -17,13 +17,13 @@ rec {
foo."bar.runtimeGraph" = mkDerivation {
name = "dependencies";
builder = builtins.toFile "build-graph-builder" "${printRefs}";
- exportReferencesGraph = ["refs" (import ./dependencies.nix)];
+ exportReferencesGraph = ["refs" (import ./dependencies.nix {})];
};
foo."bar.buildGraph" = mkDerivation {
name = "dependencies";
builder = builtins.toFile "build-graph-builder" "${printRefs}";
- exportReferencesGraph = ["refs" (import ./dependencies.nix).drvPath];
+ exportReferencesGraph = ["refs" (import ./dependencies.nix {}).drvPath];
};
}