aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-tryeval.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2023-12-01 13:53:13 -0500
committerGitHub <noreply@github.com>2023-12-01 13:53:13 -0500
commit211b6e18556e03829ae7bba38c7272af2900a2e8 (patch)
treebfcfef3efeb73cb0c3c6d812280191d03bda1233 /tests/functional/lang/eval-okay-tryeval.nix
parent72425212657d795dc215b334b7c8c8cd36d06b72 (diff)
parentf7f37035c81fa825a4dfc2df1ad2589013ac6380 (diff)
Merge pull request #9517 from NixOS/2.18-flatten-tests
[Backport 2.18-maintanence] Backport test source layout reorgs
Diffstat (limited to 'tests/functional/lang/eval-okay-tryeval.nix')
-rw-r--r--tests/functional/lang/eval-okay-tryeval.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-okay-tryeval.nix b/tests/functional/lang/eval-okay-tryeval.nix
new file mode 100644
index 000000000..629bc440a
--- /dev/null
+++ b/tests/functional/lang/eval-okay-tryeval.nix
@@ -0,0 +1,5 @@
+{
+ x = builtins.tryEval "x";
+ y = builtins.tryEval (assert false; "y");
+ z = builtins.tryEval (throw "bla");
+}