aboutsummaryrefslogtreecommitdiff
path: root/tests/gc-concurrent.nix
diff options
context:
space:
mode:
authorregnat <rg@regnat.ovh>2020-07-02 15:43:35 +0200
committerregnat <rg@regnat.ovh>2020-07-02 16:13:36 +0200
commitc762385457ce9e34536ba5de0b144d16d25ffbf6 (patch)
treea414c5a551aff777dac4171337cc2db8e3e597b2 /tests/gc-concurrent.nix
parent1b5aa60767f4a918250b157de054e1862240ca10 (diff)
Make the gc-concurrent test more reliable
Use a fifo pipe to handle the synchronisation between the different threads rather than relying on delays
Diffstat (limited to 'tests/gc-concurrent.nix')
-rw-r--r--tests/gc-concurrent.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/gc-concurrent.nix b/tests/gc-concurrent.nix
index 21671ea2c..0aba1f983 100644
--- a/tests/gc-concurrent.nix
+++ b/tests/gc-concurrent.nix
@@ -1,5 +1,7 @@
with import ./config.nix;
+{ lockFifo ? null }:
+
rec {
input1 = mkDerivation {
@@ -16,6 +18,7 @@ rec {
name = "gc-concurrent";
builder = ./gc-concurrent.builder.sh;
inherit input1 input2;
+ inherit lockFifo;
};
test2 = mkDerivation {