aboutsummaryrefslogtreecommitdiff
path: root/tests/lang/eval-fail-toJSON.nix
diff options
context:
space:
mode:
authorRobert Hensing <robert@roberthensing.nl>2023-06-30 01:29:11 +0200
committerRobert Hensing <robert@roberthensing.nl>2023-07-31 13:02:54 +0200
commit33d58a90c26f9a62bb20863b767c0a505e6f997a (patch)
treea78863601e7febc70c69d505b1c6f4847701d116 /tests/lang/eval-fail-toJSON.nix
parent2d1d81114d72ace89ce08cd3bc93f4eb27a2975d (diff)
toJSON: Add attribute path to trace
Diffstat (limited to 'tests/lang/eval-fail-toJSON.nix')
-rw-r--r--tests/lang/eval-fail-toJSON.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/lang/eval-fail-toJSON.nix b/tests/lang/eval-fail-toJSON.nix
new file mode 100644
index 000000000..8112e1c1f
--- /dev/null
+++ b/tests/lang/eval-fail-toJSON.nix
@@ -0,0 +1,10 @@
+builtins.toJSON {
+ a.b = [
+ true
+ false
+ "it's a bird"
+ {
+ c.d = throw "hah no";
+ }
+ ];
+}