aboutsummaryrefslogtreecommitdiff
path: root/tests/lang/eval-okay-arithmetic.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2023-10-05 12:12:18 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2023-12-01 12:06:43 -0500
commit30dcc19d1f30fc203be460134c4578509cce704f (patch)
tree6cc32609b9984a2c4d5ecc0cac5cf30609e208b9 /tests/lang/eval-okay-arithmetic.nix
parent72425212657d795dc215b334b7c8c8cd36d06b72 (diff)
Put functional tests in `tests/functional`
I think it is bad for these reasons when `tests/` contains a mix of functional and integration tests - Concepts is harder to understand, the documentation makes a good unit vs functional vs integration distinction, but when the integration tests are just two subdirs within `tests/` this is not clear. - Source filtering in the `flake.nix` is more complex. We need to filter out some of the dirs from `tests/`, rather than simply pick the dirs we want and take all of them. This is a good sign the structure of what we are trying to do is not matching the structure of the files. With this change we have a clean: ```shell-session $ git show 'HEAD:tests' tree HEAD:tests functional/ installer/ nixos/ ``` (cherry picked from commit 68c81c737571794f7246db53fb4774e94fcf4b7e)
Diffstat (limited to 'tests/lang/eval-okay-arithmetic.nix')
-rw-r--r--tests/lang/eval-okay-arithmetic.nix59
1 files changed, 0 insertions, 59 deletions
diff --git a/tests/lang/eval-okay-arithmetic.nix b/tests/lang/eval-okay-arithmetic.nix
deleted file mode 100644
index 7e9e6a0b6..000000000
--- a/tests/lang/eval-okay-arithmetic.nix
+++ /dev/null
@@ -1,59 +0,0 @@
-with import ./lib.nix;
-
-let {
-
- /* Supposedly tail recursive version:
-
- range_ = accum: first: last:
- if first == last then ([first] ++ accum)
- else range_ ([first] ++ accum) (builtins.add first 1) last;
-
- range = range_ [];
- */
-
- x = 12;
-
- err = abort "urgh";
-
- body = sum
- [ (sum (range 1 50))
- (123 + 456)
- (0 + -10 + -(-11) + -x)
- (10 - 7 - -2)
- (10 - (6 - -1))
- (10 - 1 + 2)
- (3 * 4 * 5)
- (56088 / 123 / 2)
- (3 + 4 * const 5 0 - 6 / id 2)
-
- (builtins.bitAnd 12 10) # 0b1100 & 0b1010 = 8
- (builtins.bitOr 12 10) # 0b1100 | 0b1010 = 14
- (builtins.bitXor 12 10) # 0b1100 ^ 0b1010 = 6
-
- (if 3 < 7 then 1 else err)
- (if 7 < 3 then err else 1)
- (if 3 < 3 then err else 1)
-
- (if 3 <= 7 then 1 else err)
- (if 7 <= 3 then err else 1)
- (if 3 <= 3 then 1 else err)
-
- (if 3 > 7 then err else 1)
- (if 7 > 3 then 1 else err)
- (if 3 > 3 then err else 1)
-
- (if 3 >= 7 then err else 1)
- (if 7 >= 3 then 1 else err)
- (if 3 >= 3 then 1 else err)
-
- (if 2 > 1 == 1 < 2 then 1 else err)
- (if 1 + 2 * 3 >= 7 then 1 else err)
- (if 1 + 2 * 3 < 7 then err else 1)
-
- # Not integer, but so what.
- (if "aa" < "ab" then 1 else err)
- (if "aa" < "aa" then err else 1)
- (if "foo" < "foobar" then 1 else err)
- ];
-
-}