aboutsummaryrefslogtreecommitdiff
path: root/tests/lang/eval-okay-fromjson.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-07-04 13:34:15 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-07-04 13:34:15 +0200
commitbeaf3e90aff14664b98f2c7ab7387c9fa4354fd1 (patch)
treecc1bab6524c7e616697efbae788e4b997a3213c4 /tests/lang/eval-okay-fromjson.nix
parente82951fe23daa961ef18b0c5cc9ba1f5d8906186 (diff)
Add builtin function ‘fromJSON’
Fixes #294.
Diffstat (limited to 'tests/lang/eval-okay-fromjson.nix')
-rw-r--r--tests/lang/eval-okay-fromjson.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-fromjson.nix b/tests/lang/eval-okay-fromjson.nix
new file mode 100644
index 000000000..5ed0c1c43
--- /dev/null
+++ b/tests/lang/eval-okay-fromjson.nix
@@ -0,0 +1,32 @@
+# RFC 7159, section 13.
+builtins.fromJSON
+ ''
+ {
+ "Image": {
+ "Width": 800,
+ "Height": 600,
+ "Title": "View from 15th Floor",
+ "Thumbnail": {
+ "Url": "http://www.example.com/image/481989943",
+ "Height": 125,
+ "Width": 100
+ },
+ "Animated" : false,
+ "IDs": [116, 943, 234, 38793, true ,false,null, -100]
+ }
+ }
+ ''
+==
+ { Image =
+ { Width = 800;
+ Height = 600;
+ Title = "View from 15th Floor";
+ Thumbnail =
+ { Url = http://www.example.com/image/481989943;
+ Height = 125;
+ Width = 100;
+ };
+ Animated = false;
+ IDs = [ 116 943 234 38793 true false null (0-100) ];
+ };
+ }