aboutsummaryrefslogtreecommitdiff
path: root/tests/lang/eval-okay-tojson.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-11-19 00:03:11 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-11-19 00:04:11 +0100
commit77c13cdf566ffedc70d8860571afae8a6d43b552 (patch)
tree80d2c35c450911d0401e8a95d28ff9d8904b53fc /tests/lang/eval-okay-tojson.nix
parent285df765b91588e39d6f35a32e30b84c3cb5be75 (diff)
Add a toJSON primop
Diffstat (limited to 'tests/lang/eval-okay-tojson.nix')
-rw-r--r--tests/lang/eval-okay-tojson.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-tojson.nix b/tests/lang/eval-okay-tojson.nix
new file mode 100644
index 000000000..0d4e55b3d
--- /dev/null
+++ b/tests/lang/eval-okay-tojson.nix
@@ -0,0 +1,11 @@
+builtins.toJSON
+ { a = 123;
+ b = -456;
+ c = "foo";
+ d = "foo\n\"bar\"";
+ e = true;
+ f = false;
+ g = [ 1 2 3 ];
+ h = [ "a" [ "b" { "foo\nbar" = {}; } ] ];
+ i = 1 + 2;
+ }