aboutsummaryrefslogtreecommitdiff
path: root/tests/lang/eval-okay-versions.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2023-10-05 12:12:18 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2023-12-01 12:06:43 -0500
commit30dcc19d1f30fc203be460134c4578509cce704f (patch)
tree6cc32609b9984a2c4d5ecc0cac5cf30609e208b9 /tests/lang/eval-okay-versions.nix
parent72425212657d795dc215b334b7c8c8cd36d06b72 (diff)
Put functional tests in `tests/functional`
I think it is bad for these reasons when `tests/` contains a mix of functional and integration tests - Concepts is harder to understand, the documentation makes a good unit vs functional vs integration distinction, but when the integration tests are just two subdirs within `tests/` this is not clear. - Source filtering in the `flake.nix` is more complex. We need to filter out some of the dirs from `tests/`, rather than simply pick the dirs we want and take all of them. This is a good sign the structure of what we are trying to do is not matching the structure of the files. With this change we have a clean: ```shell-session $ git show 'HEAD:tests' tree HEAD:tests functional/ installer/ nixos/ ``` (cherry picked from commit 68c81c737571794f7246db53fb4774e94fcf4b7e)
Diffstat (limited to 'tests/lang/eval-okay-versions.nix')
-rw-r--r--tests/lang/eval-okay-versions.nix43
1 files changed, 0 insertions, 43 deletions
diff --git a/tests/lang/eval-okay-versions.nix b/tests/lang/eval-okay-versions.nix
deleted file mode 100644
index e9111f5f4..000000000
--- a/tests/lang/eval-okay-versions.nix
+++ /dev/null
@@ -1,43 +0,0 @@
-let
-
- name1 = "hello-1.0.2";
- name2 = "hello";
- name3 = "915resolution-0.5.2";
- name4 = "xf86-video-i810-1.7.4";
- name5 = "name-that-ends-with-dash--1.0";
-
- eq = 0;
- lt = builtins.sub 0 1;
- gt = 1;
-
- versionTest = v1: v2: expected:
- let d1 = builtins.compareVersions v1 v2;
- d2 = builtins.compareVersions v2 v1;
- in d1 == builtins.sub 0 d2 && d1 == expected;
-
- tests = [
- ((builtins.parseDrvName name1).name == "hello")
- ((builtins.parseDrvName name1).version == "1.0.2")
- ((builtins.parseDrvName name2).name == "hello")
- ((builtins.parseDrvName name2).version == "")
- ((builtins.parseDrvName name3).name == "915resolution")
- ((builtins.parseDrvName name3).version == "0.5.2")
- ((builtins.parseDrvName name4).name == "xf86-video-i810")
- ((builtins.parseDrvName name4).version == "1.7.4")
- ((builtins.parseDrvName name5).name == "name-that-ends-with-dash")
- ((builtins.parseDrvName name5).version == "-1.0")
- (versionTest "1.0" "2.3" lt)
- (versionTest "2.1" "2.3" lt)
- (versionTest "2.3" "2.3" eq)
- (versionTest "2.5" "2.3" gt)
- (versionTest "3.1" "2.3" gt)
- (versionTest "2.3.1" "2.3" gt)
- (versionTest "2.3.1" "2.3a" gt)
- (versionTest "2.3pre1" "2.3" lt)
- (versionTest "2.3pre3" "2.3pre12" lt)
- (versionTest "2.3a" "2.3c" lt)
- (versionTest "2.3pre1" "2.3c" lt)
- (versionTest "2.3pre1" "2.3q" lt)
- ];
-
-in (import ./lib.nix).and tests