aboutsummaryrefslogtreecommitdiff
path: root/tests/modules/declare-set.nix
diff options
context:
space:
mode:
authorRobert Hensing <robert@roberthensing.nl>2023-08-16 15:46:37 +0200
committerRobert Hensing <robert@roberthensing.nl>2023-08-16 15:46:37 +0200
commit63e0b5d081fed582ac6a0a66f402dc525953524b (patch)
tree1bdcd7fc8a6a40b2e805bad759b36e64e911036b /tests/modules/declare-set.nix
GC root for fetched nixpkgs/lib content
Diffstat (limited to 'tests/modules/declare-set.nix')
-rw-r--r--tests/modules/declare-set.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/modules/declare-set.nix b/tests/modules/declare-set.nix
new file mode 100644
index 000000000..853418531
--- /dev/null
+++ b/tests/modules/declare-set.nix
@@ -0,0 +1,12 @@
+{ lib, ... }:
+
+{
+ options.set = lib.mkOption {
+ default = { };
+ example = { a = 1; };
+ type = lib.types.attrsOf lib.types.int;
+ description = ''
+ Some descriptive text
+ '';
+ };
+}