aboutsummaryrefslogtreecommitdiff
path: root/tests/nixos/nix-copy.nix
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-03-09 11:01:28 +0100
committereldritch horrors <pennae@lix.systems>2024-03-10 10:10:52 +0100
commit34fb7a7e9d92698a721862fe0ef926d69b12a8e5 (patch)
treec347f8e165f771a41040f6e9b795b1421113c99e /tests/nixos/nix-copy.nix
parent609a8e0d94926cae460ed6f12f1f8a3d9f91246b (diff)
make the multi-node vm tests a bit more reliable
without these changes the tests will very repeatably (although not very reliably) wedge in our runs. the ssh command starts, opens a sessions, does something, the session closes again, but the test does not move on. adding *just* the redirect and not the unit waits is not sufficient either, it needs both. this feels like a bug in the nixos testing framework somewhere, but digging that far is not in the cards right now. Change-Id: Idab577b83a36cc4899bb5ffbb3d9adc04e83e51c
Diffstat (limited to 'tests/nixos/nix-copy.nix')
-rw-r--r--tests/nixos/nix-copy.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/tests/nixos/nix-copy.nix b/tests/nixos/nix-copy.nix
index 7db5197aa..3bcc7a988 100644
--- a/tests/nixos/nix-copy.nix
+++ b/tests/nixos/nix-copy.nix
@@ -54,8 +54,12 @@ in {
start_all()
- server.wait_for_unit("sshd")
- client.wait_for_unit("network.target")
+ server.succeed("systemctl start network-online.target")
+ client.succeed("systemctl start network-online.target")
+ server.wait_for_unit("network-online.target")
+ client.wait_for_unit("network-online.target")
+
+ server.wait_for_unit("sshd.service")
client.wait_for_unit("getty@tty1.service")
# Either the prompt: ]#
# or an OCR misreading of it: 1#
@@ -82,7 +86,7 @@ in {
# Install the SSH key on the server.
server.copy_from_host("key.pub", "/root/.ssh/authorized_keys")
server.succeed("systemctl restart sshd")
- client.succeed(f"ssh -o StrictHostKeyChecking=no {server.name} 'echo hello world'")
+ client.succeed(f"ssh -o StrictHostKeyChecking=no {server.name} 'echo hello world' >&2")
client.succeed(f"ssh -O check {server.name}")
client.succeed(f"ssh -O exit {server.name}")
client.fail(f"ssh -O check {server.name}")