aboutsummaryrefslogtreecommitdiff
path: root/tests/nixos/no-new-privileges/package.nix
diff options
context:
space:
mode:
authorAlois Wohlschlager <alois1@gmx-topmail.de>2024-05-08 19:15:00 +0200
committeralois31 <alois1@gmx-topmail.de>2024-05-24 21:19:29 +0000
commitf047e4357b4f7ad66c2e476506bf35cab82e441e (patch)
treefcfc0bd4776ca73e19f5125aa9d7f778fc8b3fc7 /tests/nixos/no-new-privileges/package.nix
parent19ea351642d48a49a2b41248cbbc4569aa16c0a9 (diff)
libstore/build: always enable seccomp filtering and no-new-privileges
Seccomp filtering and the no-new-privileges functionality improve the security of the sandbox, and have been enabled by default for a long time. In https://git.lix.systems/lix-project/lix/issues/265 it was decided that they should be enabled unconditionally. Accordingly, remove the allow-new-privileges (which had weird behavior anyway) and filter-syscall settings, and force the security features on. Syscall filtering can still be enabled at build time to support building on architectures libseccomp doesn't support. Change-Id: Iedbfa18d720ae557dee07a24f69b2520f30119cb
Diffstat (limited to 'tests/nixos/no-new-privileges/package.nix')
-rw-r--r--tests/nixos/no-new-privileges/package.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/nixos/no-new-privileges/package.nix b/tests/nixos/no-new-privileges/package.nix
new file mode 100644
index 000000000..55c96bc2e
--- /dev/null
+++ b/tests/nixos/no-new-privileges/package.nix
@@ -0,0 +1,8 @@
+{ runCommand, libcap }:
+runCommand "cant-get-capabilities" { nativeBuildInputs = [ libcap.out ]; } ''
+ if [ "$(/run/wrappers/bin/ohno 2>&1)" != "failed to inherit capabilities: Operation not permitted" ]; then
+ echo "Oh no! We gained capabilities!"
+ exit 1
+ fi
+ touch $out
+''