aboutsummaryrefslogtreecommitdiff
path: root/tests/nixos/root-in-sandbox/default.nix
diff options
context:
space:
mode:
authorAlois Wohlschlager <alois1@gmx-topmail.de>2024-05-08 19:15:00 +0200
committeralois31 <alois1@gmx-topmail.de>2024-05-24 21:19:29 +0000
commitf047e4357b4f7ad66c2e476506bf35cab82e441e (patch)
treefcfc0bd4776ca73e19f5125aa9d7f778fc8b3fc7 /tests/nixos/root-in-sandbox/default.nix
parent19ea351642d48a49a2b41248cbbc4569aa16c0a9 (diff)
libstore/build: always enable seccomp filtering and no-new-privileges
Seccomp filtering and the no-new-privileges functionality improve the security of the sandbox, and have been enabled by default for a long time. In https://git.lix.systems/lix-project/lix/issues/265 it was decided that they should be enabled unconditionally. Accordingly, remove the allow-new-privileges (which had weird behavior anyway) and filter-syscall settings, and force the security features on. Syscall filtering can still be enabled at build time to support building on architectures libseccomp doesn't support. Change-Id: Iedbfa18d720ae557dee07a24f69b2520f30119cb
Diffstat (limited to 'tests/nixos/root-in-sandbox/default.nix')
-rw-r--r--tests/nixos/root-in-sandbox/default.nix15
1 files changed, 0 insertions, 15 deletions
diff --git a/tests/nixos/root-in-sandbox/default.nix b/tests/nixos/root-in-sandbox/default.nix
deleted file mode 100644
index 110d83f86..000000000
--- a/tests/nixos/root-in-sandbox/default.nix
+++ /dev/null
@@ -1,15 +0,0 @@
-let
- inherit (import ../util.nix) mkNixBuildTest;
-in mkNixBuildTest {
- name = "root-in-sandbox";
- extraMachineConfig = { pkgs, ... }: {
- security.wrappers.ohno = {
- owner = "root";
- group = "root";
- setuid = true;
- source = "${pkgs.coreutils}/bin/whoami";
- };
- nix.settings.extra-sandbox-paths = ["/run/wrappers/bin"];
- };
- expressionFile = ./package.nix;
-}