aboutsummaryrefslogtreecommitdiff
path: root/tests/nixos/sourcehut-flakes.nix
diff options
context:
space:
mode:
authorRobert Hensing <robert@roberthensing.nl>2023-01-20 15:32:31 +0100
committerRobert Hensing <robert@roberthensing.nl>2023-01-20 16:23:52 +0100
commit261c25601d9a4efd5245e3ef161fb52bf0543083 (patch)
tree96558cc1ad6efeb7c03255b46eb2768d30216359 /tests/nixos/sourcehut-flakes.nix
parent74026bb1014460d511534da8a955bee6948716ee (diff)
Use the official, documented NixOS runTest interface
Diffstat (limited to 'tests/nixos/sourcehut-flakes.nix')
-rw-r--r--tests/nixos/sourcehut-flakes.nix14
1 files changed, 4 insertions, 10 deletions
diff --git a/tests/nixos/sourcehut-flakes.nix b/tests/nixos/sourcehut-flakes.nix
index b77496ab6..a76fed020 100644
--- a/tests/nixos/sourcehut-flakes.nix
+++ b/tests/nixos/sourcehut-flakes.nix
@@ -1,12 +1,8 @@
-{ nixpkgs, system, overlay }:
-
-with import (nixpkgs + "/nixos/lib/testing-python.nix")
-{
- inherit system;
- extraConfigurations = [{ nixpkgs.overlays = [ overlay ]; }];
-};
+{ lib, config, hostPkgs, nixpkgs, ... }:
let
+ pkgs = config.nodes.sourcehut.nixpkgs.pkgs;
+
# Generate a fake root CA and a fake git.sr.ht certificate.
cert = pkgs.runCommand "cert" { buildInputs = [ pkgs.openssl ]; }
''
@@ -64,8 +60,6 @@ let
in
-makeTest (
-
{
name = "sourcehut-flakes";
@@ -164,4 +158,4 @@ makeTest (
client.succeed("nix build nixpkgs#fuse --tarball-ttl 0")
'';
- })
+}