aboutsummaryrefslogtreecommitdiff
path: root/tests/remote-builds.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2019-10-04 10:45:33 +0200
committerEelco Dolstra <edolstra@gmail.com>2019-10-04 10:45:33 +0200
commit204291f0598c43b10cf20a89b49fc63624d78c7c (patch)
tree50e8ef983c104c970e9c3e4354f755f8bb0622a7 /tests/remote-builds.nix
parent90d6018509e60fd07d93ddefbf6f983a72d4b587 (diff)
Merge release.nix, shell.nix and release-common.nix into flake.nix
Also provide a Nixpkgs overlay, memoize Nixpkgs evaluation and fit the githubFlakes test.
Diffstat (limited to 'tests/remote-builds.nix')
-rw-r--r--tests/remote-builds.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/tests/remote-builds.nix b/tests/remote-builds.nix
index b867f13b4..a53f9bfcd 100644
--- a/tests/remote-builds.nix
+++ b/tests/remote-builds.nix
@@ -1,8 +1,11 @@
# Test Nix's remote build feature.
-{ nixpkgs, system, nix }:
+{ nixpkgs, system, overlay }:
-with import (nixpkgs + "/nixos/lib/testing.nix") { inherit system; };
+with import (nixpkgs + "/nixos/lib/testing.nix") {
+ inherit system;
+ extraConfigurations = [ { nixpkgs.overlays = [ overlay ]; } ];
+};
makeTest (
@@ -13,7 +16,6 @@ let
{ config, pkgs, ... }:
{ services.openssh.enable = true;
virtualisation.writableStore = true;
- nix.package = nix;
nix.useSandbox = true;
};
@@ -59,7 +61,6 @@ in
];
virtualisation.writableStore = true;
virtualisation.pathsInNixDB = [ config.system.build.extraUtils ];
- nix.package = nix;
nix.binaryCaches = [ ];
programs.ssh.extraConfig = "ConnectTimeout 30";
};