aboutsummaryrefslogtreecommitdiff
path: root/tests/remote-builds.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2011-11-25 17:04:26 +0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2011-11-25 17:04:26 +0000
commit784083176a6c2bbda84095de97cb59126fe7c7a5 (patch)
tree33d58256c49c274724b5c60d912d8b015fbf47e7 /tests/remote-builds.nix
parentf3bc98b0015fe333f7b1ef342143c23d0d6a2aa5 (diff)
* Fix race.
Diffstat (limited to 'tests/remote-builds.nix')
-rw-r--r--tests/remote-builds.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/remote-builds.nix b/tests/remote-builds.nix
index 201ca9dba..de127b8ae 100644
--- a/tests/remote-builds.nix
+++ b/tests/remote-builds.nix
@@ -72,6 +72,7 @@ in
$client->succeed("chmod 600 /root/.ssh/id_dsa");
# Install the SSH key on the slaves.
+ $client->waitForJob("network-interfaces");
foreach my $slave ($slave1, $slave2) {
$slave->succeed("mkdir -m 700 /root/.ssh");
$slave->copyFileFromHost("key.pub", "/root/.ssh/authorized_keys");