aboutsummaryrefslogtreecommitdiff
path: root/tests/search.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2023-10-05 12:12:18 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2023-12-01 12:06:43 -0500
commit30dcc19d1f30fc203be460134c4578509cce704f (patch)
tree6cc32609b9984a2c4d5ecc0cac5cf30609e208b9 /tests/search.nix
parent72425212657d795dc215b334b7c8c8cd36d06b72 (diff)
Put functional tests in `tests/functional`
I think it is bad for these reasons when `tests/` contains a mix of functional and integration tests - Concepts is harder to understand, the documentation makes a good unit vs functional vs integration distinction, but when the integration tests are just two subdirs within `tests/` this is not clear. - Source filtering in the `flake.nix` is more complex. We need to filter out some of the dirs from `tests/`, rather than simply pick the dirs we want and take all of them. This is a good sign the structure of what we are trying to do is not matching the structure of the files. With this change we have a clean: ```shell-session $ git show 'HEAD:tests' tree HEAD:tests functional/ installer/ nixos/ ``` (cherry picked from commit 68c81c737571794f7246db53fb4774e94fcf4b7e)
Diffstat (limited to 'tests/search.nix')
-rw-r--r--tests/search.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/tests/search.nix b/tests/search.nix
deleted file mode 100644
index fea6e7a7a..000000000
--- a/tests/search.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-with import ./config.nix;
-
-{
- hello = mkDerivation rec {
- name = "hello-${version}";
- version = "0.1";
- buildCommand = "touch $out";
- meta.description = "Empty file";
- };
- foo = mkDerivation rec {
- name = "foo-5";
- buildCommand = ''
- mkdir -p $out
- echo ${name} > $out/${name}
- '';
- };
- bar = mkDerivation rec {
- name = "bar-3";
- buildCommand = ''
- echo "Does not build successfully"
- exit 1
- '';
- meta.description = "broken bar";
- };
-}