aboutsummaryrefslogtreecommitdiff
path: root/tests/shell-hello.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2022-05-12 19:13:33 +0000
committerJohn Ericson <John.Ericson@Obsidian.Systems>2022-05-12 19:13:33 +0000
commitb18720ee175d6c019be964955efc1633be1c434d (patch)
treeda1daaed8a0c3c45829ba9285f328d31e09476b8 /tests/shell-hello.nix
parent6b61d7722d0b24bc4b5e020a71ada442c19f495d (diff)
parentd354fc30b9768ea3dc737a88b57bf5e26d98135b (diff)
Merge remote-tracking branch 'upstream/master' into indexed-store-path-outputs
Diffstat (limited to 'tests/shell-hello.nix')
-rw-r--r--tests/shell-hello.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/tests/shell-hello.nix b/tests/shell-hello.nix
index 77dcbd2a9..3fdd3501d 100644
--- a/tests/shell-hello.nix
+++ b/tests/shell-hello.nix
@@ -3,15 +3,24 @@ with import ./config.nix;
{
hello = mkDerivation {
name = "hello";
+ outputs = [ "out" "dev" ];
+ meta.outputsToInstall = [ "out" ];
buildCommand =
''
- mkdir -p $out/bin
+ mkdir -p $out/bin $dev/bin
+
cat > $out/bin/hello <<EOF
#! ${shell}
who=\$1
echo "Hello \''${who:-World} from $out/bin/hello"
EOF
chmod +x $out/bin/hello
+
+ cat > $dev/bin/hello2 <<EOF
+ #! ${shell}
+ echo "Hello2"
+ EOF
+ chmod +x $dev/bin/hello2
'';
};
}