aboutsummaryrefslogtreecommitdiff
path: root/tests/shell.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2017-04-25 18:59:18 +0200
committerEelco Dolstra <edolstra@gmail.com>2017-04-25 18:59:18 +0200
commit4c95ef3768f8415579d9dd8bda69407021b72017 (patch)
tree9ac8d07479423d26a84585e099b3f8fc698bcbe6 /tests/shell.nix
parent536f06176519072011aebe0d9b4b5b75e1691f67 (diff)
Fix nix-shell test
Diffstat (limited to 'tests/shell.nix')
-rw-r--r--tests/shell.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/shell.nix b/tests/shell.nix
index 1a092913b..5845d36fc 100644
--- a/tests/shell.nix
+++ b/tests/shell.nix
@@ -2,7 +2,7 @@
with import ./config.nix;
-rec {
+let pkgs = rec {
setupSh = builtins.toFile "setup" ''
export VAR_FROM_STDENV_SETUP=foo
for pkg in $buildInputs; do
@@ -44,4 +44,6 @@ rec {
'';
bash = shell;
-}
+
+ inherit pkgs;
+}; in pkgs