aboutsummaryrefslogtreecommitdiff
path: root/tests/shell.nix
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas@tuxera.com>2017-01-01 18:45:51 +0200
committerTuomas Tynkkynen <tuomas@tuxera.com>2017-01-03 10:11:09 +0200
commitb501bea25fac9c43dfd0d197e16836facd2b63a5 (patch)
treed25d160845444d86417c593c4309ccbdc59e2e55 /tests/shell.nix
parent018f884ffd834ee339e9b4182b4537a3cd80ee28 (diff)
tests: Add simple tests for nix-shell
nix-shell -A, -p and -i are lightly tested.
Diffstat (limited to 'tests/shell.nix')
-rw-r--r--tests/shell.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/tests/shell.nix b/tests/shell.nix
new file mode 100644
index 000000000..ed4d6fbaa
--- /dev/null
+++ b/tests/shell.nix
@@ -0,0 +1,46 @@
+{ }:
+
+with import ./config.nix;
+
+rec {
+ setupSh = builtins.toFile "setup" ''
+ export VAR_FROM_STDENV_SETUP=foo
+ for pkg in $buildInputs; do
+ export PATH=$PATH:$pkg/bin
+ done
+ '';
+
+ stdenv = mkDerivation {
+ name = "stdenv";
+ buildCommand = ''
+ mkdir -p $out
+ ln -s ${setupSh} $out/setup
+ '';
+ };
+
+ shellDrv = mkDerivation {
+ name = "shellDrv";
+ builder = "/does/not/exist";
+ VAR_FROM_NIX = "bar";
+ inherit stdenv;
+ };
+
+ # Used by nix-shell -p
+ runCommand = name: args: buildCommand: mkDerivation (args // {
+ inherit name buildCommand stdenv;
+ });
+
+ foo = runCommand "foo" {} ''
+ mkdir -p $out/bin
+ echo 'echo foo' > $out/bin/foo
+ chmod a+rx $out/bin/foo
+ '';
+
+ bar = runCommand "bar" {} ''
+ mkdir -p $out/bin
+ echo 'echo bar' > $out/bin/bar
+ chmod a+rx $out/bin/bar
+ '';
+
+ bash = shell;
+}