aboutsummaryrefslogtreecommitdiff
path: root/tests/shell.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2021-07-09 01:17:32 +0200
committerEelco Dolstra <edolstra@gmail.com>2021-07-09 01:18:44 +0200
commite50408bd3192156e04571a1546d053f998ab4e2c (patch)
tree05f6581cbabdbc1d7da7cbcc7ede40662710706c /tests/shell.nix
parent9fc7da1e08d83378f8b0d66a060d92929c1468cf (diff)
nix develop: Add a test for bash functions
Diffstat (limited to 'tests/shell.nix')
-rw-r--r--tests/shell.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/shell.nix b/tests/shell.nix
index 1f5526253..70c60276c 100644
--- a/tests/shell.nix
+++ b/tests/shell.nix
@@ -22,6 +22,9 @@ let pkgs = rec {
done
declare -a arr1=(1 2 "3 4" 5)
declare -a arr2=(x $'\n' $'x\ny')
+ fun() {
+ echo blabla
+ }
'';
stdenv = mkDerivation {