aboutsummaryrefslogtreecommitdiff
path: root/tests/structured-attrs-shell.nix
diff options
context:
space:
mode:
authorMaximilian Bosch <maximilian@mbosch.me>2021-05-18 15:07:30 +0200
committerMaximilian Bosch <maximilian@mbosch.me>2021-06-22 19:15:57 +0200
commit3504c811a55ecd58e0712cf24829c67c192f5e80 (patch)
tree97d291caa783961a4c55e3d39c1fac0097de0f20 /tests/structured-attrs-shell.nix
parentf1e281c4fe1263a0c848bc8aaf57a0e61a99fa93 (diff)
Add testcase for `nix develop` with `__structuredAttrs`
Diffstat (limited to 'tests/structured-attrs-shell.nix')
-rw-r--r--tests/structured-attrs-shell.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/structured-attrs-shell.nix b/tests/structured-attrs-shell.nix
index 0c01c2568..57c1e6bd2 100644
--- a/tests/structured-attrs-shell.nix
+++ b/tests/structured-attrs-shell.nix
@@ -6,10 +6,12 @@ let
mkdir $out; echo bla > $out/bla
'';
};
+ inherit (import ./shell.nix { inNixShell = true; }) stdenv;
in
mkDerivation {
name = "structured2";
__structuredAttrs = true;
+ inherit stdenv;
outputs = [ "out" "dev" ];
my.list = [ "a" "b" "c" ];
exportReferencesGraph.refs = [ dep ];