aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1d4b7d3b8..a30e0c3b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -261,6 +261,23 @@ AC_MSG_RESULT(yes)
AC_SUBST(perlFlags)
+# Check for otool, an optional dependency on Darwin.
+AC_PATH_PROG(otool, otool)
+AC_MSG_CHECKING([that otool works])
+case $host_os in
+ darwin*)
+ if test -z "$otool" || ! $otool --version 2>/dev/null; then
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([Can't get version from otool; do you need to install developer tools?])
+ fi
+ AC_MSG_RESULT(yes)
+ ;;
+ *)
+ AC_MSG_RESULT(not needed)
+ ;;
+esac
+
+
# Whether to build the Perl bindings
AC_MSG_CHECKING([whether to build the Perl bindings])
AC_ARG_ENABLE(perl-bindings, AC_HELP_STRING([--enable-perl-bindings],