aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bc024c69c..c10c56276 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,6 +71,15 @@ fi
AC_PROG_CC
AC_PROG_CXX
+# To build programs to be run in the build machine
+if test "$CC_FOR_BUILD" = ""; then
+ if test "$cross_compiling" = "yes"; then
+ AC_CHECK_PROGS(CC_FOR_BUILD, gcc cc)
+ else
+ CC_FOR_BUILD="$CC"
+ fi
+fi
+AC_SUBST([CC_FOR_BUILD])
# We are going to use libtool.
AC_DISABLE_STATIC