aboutsummaryrefslogtreecommitdiff
path: root/corepkgs/call-flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'corepkgs/call-flake.nix')
-rw-r--r--corepkgs/call-flake.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/corepkgs/call-flake.nix b/corepkgs/call-flake.nix
index 29ff41040..c59a0c75f 100644
--- a/corepkgs/call-flake.nix
+++ b/corepkgs/call-flake.nix
@@ -1,14 +1,14 @@
-locks: rootSrc:
+locks: rootSrc: rootSubdir:
let
- callFlake = sourceInfo: locks:
+ callFlake = sourceInfo: subdir: locks:
let
- flake = import (sourceInfo + "/flake.nix");
+ flake = import (sourceInfo + "/" + subdir + "/flake.nix");
inputs = builtins.mapAttrs (n: v:
if v.flake or true
- then callFlake (fetchTree v.locked) v.inputs
+ then callFlake (fetchTree (removeAttrs v.locked ["dir"])) (v.locked.dir or "") v.inputs
else fetchTree v.locked) locks;
outputs = flake.outputs (inputs // { self = result; });
@@ -19,4 +19,4 @@ let
result;
-in callFlake rootSrc (builtins.fromJSON locks).inputs
+in callFlake rootSrc rootSubdir (builtins.fromJSON locks).inputs