aboutsummaryrefslogtreecommitdiff
path: root/corepkgs/derivation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'corepkgs/derivation.nix')
-rw-r--r--corepkgs/derivation.nix27
1 files changed, 0 insertions, 27 deletions
diff --git a/corepkgs/derivation.nix b/corepkgs/derivation.nix
deleted file mode 100644
index c0fbe8082..000000000
--- a/corepkgs/derivation.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-/* This is the implementation of the ‘derivation’ builtin function.
- It's actually a wrapper around the ‘derivationStrict’ primop. */
-
-drvAttrs @ { outputs ? [ "out" ], ... }:
-
-let
-
- strict = derivationStrict drvAttrs;
-
- commonAttrs = drvAttrs // (builtins.listToAttrs outputsList) //
- { all = map (x: x.value) outputsList;
- inherit drvAttrs;
- };
-
- outputToAttrListElement = outputName:
- { name = outputName;
- value = commonAttrs // {
- outPath = builtins.getAttr outputName strict;
- drvPath = strict.drvPath;
- type = "derivation";
- inherit outputName;
- };
- };
-
- outputsList = map outputToAttrListElement outputs;
-
-in (builtins.head outputsList).value