aboutsummaryrefslogtreecommitdiff
path: root/corepkgs/unpack-channel.nix
diff options
context:
space:
mode:
Diffstat (limited to 'corepkgs/unpack-channel.nix')
-rw-r--r--corepkgs/unpack-channel.nix35
1 files changed, 4 insertions, 31 deletions
diff --git a/corepkgs/unpack-channel.nix b/corepkgs/unpack-channel.nix
index d39a20637..10515bc8b 100644
--- a/corepkgs/unpack-channel.nix
+++ b/corepkgs/unpack-channel.nix
@@ -1,39 +1,12 @@
-with import <nix/config.nix>;
-
-let
-
- builder = builtins.toFile "unpack-channel.sh"
- ''
- mkdir $out
- cd $out
- xzpat="\.xz\$"
- gzpat="\.gz\$"
- if [[ "$src" =~ $xzpat ]]; then
- ${xz} -d < $src | ${tar} xf - ${tarFlags}
- elif [[ "$src" =~ $gzpat ]]; then
- ${gzip} -d < $src | ${tar} xf - ${tarFlags}
- else
- ${bzip2} -d < $src | ${tar} xf - ${tarFlags}
- fi
- if [ * != $channelName ]; then
- mv * $out/$channelName
- fi
- '';
-
-in
-
{ name, channelName, src }:
derivation {
- system = builtins.currentSystem;
- builder = shell;
- args = [ "-e" builder ];
- inherit name channelName src;
+ builder = "builtin:unpack-channel";
+
+ system = "builtin";
- PATH = "${nixBinDir}:${coreutils}";
+ inherit name channelName src;
# No point in doing this remotely.
preferLocalBuild = true;
-
- inherit chrootDeps;
}